What internet browsers does iCivics support?

In general, all browsers that support the HTML and JavaScript requirements will work, but each browser has its own little quirks that need to be specially handled. The following browsers have been tested and confirmed as compatible with the iCivics site.

Recommended Browser Versions

  • Internet Explorer 9
  • Chrome
  • Firefox 10
  • Safari 5

Minimum Browser Versions

  • Internet Explorer 8
  • Chrome
  • Firefox 3
  • Safari 4

 

Note that Win the White House and Executive Command have different requirements as newer games using WebGL technology.

Recommended Browser Versions (WebGL games)

  • Edge
  • Chrome (latest)
  • Firefox (latest)
  • Safari (latest)

Recommended Browser Versions (when using Unity Web Player as an alternative for Win the White House)

  • Internet Explorer 10+
Have more questions? Submit a request

Comments